AWS Degraded – Multiple Services in US-East-1 Region

Incident Report for Kayako

Resolved

AWS has confirmed that the outage in the US-EAST-1 region has now been resolved, and all services are operational.
Posted Oct 20, 2025 - 23:16 UTC

Identified

AWS has confirmed “increased error rates and latencies for multiple AWS Services in the US-EAST-1 Region” with a severity labelled “Degraded”.

This affects Kayako instances and you may experience issues loading your Help Centers or interacting with the Help Center.
Posted Oct 20, 2025 - 08:08 UTC
This incident affected: Help Center, Agent portal, EU Pod, and US Pod.