Servers are under heavy load due to high number of requests.
Incident Report for Kayako
Resolved
This incident has been resolved.
Posted about 2 months ago. Apr 02, 2019 - 12:44 UTC
Investigating
We are currently investigating this issue.
Posted about 2 months ago. Apr 02, 2019 - 08:00 UTC
This incident affected: US Pod.